aboutsummaryrefslogtreecommitdiffstats
path: root/pyGHDL
diff options
context:
space:
mode:
Diffstat (limited to 'pyGHDL')
-rw-r--r--pyGHDL/README.md5
-rw-r--r--pyGHDL/__init__.py0
-rw-r--r--pyGHDL/dom/Misc.py3
-rw-r--r--pyGHDL/libghdl/version.py2
-rw-r--r--pyGHDL/requirements.txt2
-rw-r--r--pyGHDL/setup.py44
6 files changed, 7 insertions, 49 deletions
diff --git a/pyGHDL/README.md b/pyGHDL/README.md
index deb45b8d8..81afcc1cb 100644
--- a/pyGHDL/README.md
+++ b/pyGHDL/README.md
@@ -4,9 +4,8 @@ Python binding for GHDL and high-level APIs.
## Provided Packages
+* `pyGHDL.cli` - Command line interface tools.
+* `pyGHDL.dom` - Document Object Model (DOM) for VHDL parsed by `libghdl`.
* `pyGHDL.libghdl` - Low-level Python bindings to GHDL's `libghdl` shared library.
Auto generated API from Ada sources.
-* `pyGHDL.cli` - Command line interface tools.
* `pyGHDL.lsp` - Language Server Protocol (LSP) implementation for VHDL.
-* `pyGHDL.dom` - Document Object Model (DOM) for VHDL parsed by `libghdl`.
-* `pyGHDL.xtools` - *tbd*
diff --git a/pyGHDL/__init__.py b/pyGHDL/__init__.py
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/pyGHDL/__init__.py
diff --git a/pyGHDL/dom/Misc.py b/pyGHDL/dom/Misc.py
index 82c1f8fac..f8c3d5b73 100644
--- a/pyGHDL/dom/Misc.py
+++ b/pyGHDL/dom/Misc.py
@@ -32,7 +32,8 @@ class Design(VHDLModel_Design):
errorout_console.Install_Handler()
libghdl.set_option(b"--std=08")
- libghdl.analyze_init()
+# if libghdl.analyze_init_status() != 0:
+# raise LibGHDLException("Error initializing 'libghdl'.")
@export
class Library(VHDLModel_Library):
diff --git a/pyGHDL/libghdl/version.py b/pyGHDL/libghdl/version.py
index fcc6d13d8..6c7936ab3 100644
--- a/pyGHDL/libghdl/version.py
+++ b/pyGHDL/libghdl/version.py
@@ -1 +1 @@
-__version__ = "1.0-dev"
+__version__ = "1.0.0-dev"
diff --git a/pyGHDL/requirements.txt b/pyGHDL/requirements.txt
new file mode 100644
index 000000000..6f7932078
--- /dev/null
+++ b/pyGHDL/requirements.txt
@@ -0,0 +1,2 @@
+pydecor>=2.0.1
+pyVHDLModel>=0.7.1
diff --git a/pyGHDL/setup.py b/pyGHDL/setup.py
deleted file mode 100644
index b76d8cd29..000000000
--- a/pyGHDL/setup.py
+++ /dev/null
@@ -1,44 +0,0 @@
-#!/usr/bin/env python
-
-from setuptools import setup, find_packages
-import re
-
-
-def get_version():
- # Try from version.py. Reads it to avoid loading the shared library.
- r = re.compile('^__version__ = "(.*)"\n')
- try:
- l = open("libghdl/version.py").read()
- m = r.match(l)
- if m:
- return m.group(1)
- except:
- pass
- raise Exception("Cannot find version")
-
-
-# Extract the version now, as setup() may change the current directory.
-version = get_version()
-
-setup(
- name="pyGHDL",
- version=version,
- description="Python bindings for GHDL and high-level APIs (incl. LSP)",
- author="Tristan Gingold",
- author_email="tgingold@free.fr",
- url="http://github.com/ghdl/ghdl",
- license="GPL-2.0-or-later",
- packages=find_packages(),
- # List run-time dependencies here. For an analysis of "install_requires"
- # vs pip's requirements files see:
- # https://packaging.python.org/en/latest/requirements.html
- install_requires=["attrs"],
- # To provide executable scripts, use entry points in preference to the
- # "scripts" keyword. Entry points provide cross-platform support and allow
- # pip to create the appropriate form of executable for the target platform.
- entry_points={
- "console_scripts": [
- "ghdl-ls = vhdl_langserver.main:main",
- ]
- },
-) \ No newline at end of file