aboutsummaryrefslogtreecommitdiffstats
path: root/icefuzz/make_aig.py
diff options
context:
space:
mode:
authorScott Shawcroft <scott.shawcroft@gmail.com>2017-07-02 15:38:44 -0700
committerScott Shawcroft <scott.shawcroft@gmail.com>2017-07-02 15:38:44 -0700
commitb00ffb1c091b65ed6c741dde74a4e7d5f709efd1 (patch)
tree37504d253d295bb2487bb5753fb22f8a8ca09d17 /icefuzz/make_aig.py
parenta25c8679ac37df5219e1d7a8cdd932288cd596b1 (diff)
downloadicestorm-b00ffb1c091b65ed6c741dde74a4e7d5f709efd1.tar.gz
icestorm-b00ffb1c091b65ed6c741dde74a4e7d5f709efd1.tar.bz2
icestorm-b00ffb1c091b65ed6c741dde74a4e7d5f709efd1.zip
Introduce device class into fuxx workign directories and have glbcheck handle unsupported 5k tiles ok.
Diffstat (limited to 'icefuzz/make_aig.py')
-rw-r--r--icefuzz/make_aig.py19
1 files changed, 10 insertions, 9 deletions
diff --git a/icefuzz/make_aig.py b/icefuzz/make_aig.py
index 14431d5..60f5946 100644
--- a/icefuzz/make_aig.py
+++ b/icefuzz/make_aig.py
@@ -4,13 +4,17 @@ from fuzzconfig import *
import numpy as np
import os
-os.system("rm -rf work_aig")
-os.mkdir("work_aig")
+device_class = os.getenv("ICEDEVICE")
+
+working_dir = "work_%s_aig" % (device_class, )
+
+os.system("rm -rf " + working_dir)
+os.mkdir(working_dir)
w = len(pins) // 2
for idx in range(num):
- with open("work_aig/aig_%02d.v" % idx, "w") as f:
+ with open(working_dir + "/aig_%02d.v" % idx, "w") as f:
print("module top(input [%d:0] a, output [%d:0] y);" % (w-1, w-1), file=f)
sigs = ["a[%d]" % i for i in range(w)]
@@ -47,14 +51,11 @@ for idx in range(num):
print("endmodule", file=f)
- with open("work_aig/aig_%02d.pcf" % idx, "w") as f:
+ with open(working_dir + "/aig_%02d.pcf" % idx, "w") as f:
p = np.random.permutation(pins)
for i in range(w):
print("set_io a[%d] %s" % (i, p[i]), file=f)
print("set_io y[%d] %s" % (i, p[i+w]), file=f)
-with open("work_aig/Makefile", "w") as f:
- print("all: %s" % " ".join(["aig_%02d.bin" % i for i in range(num)]), file=f)
- for i in range(num):
- print("aig_%02d.bin:" % i, file=f)
- print("\t-bash ../icecube.sh aig_%02d > aig_%02d.log 2>&1 && rm -rf aig_%02d.tmp || tail aig_%02d.log" % (i, i, i, i), file=f)
+
+output_makefile(working_dir, "aig")