aboutsummaryrefslogtreecommitdiffstats
path: root/icefuzz/make_fanout.py
diff options
context:
space:
mode:
authorScott Shawcroft <scott.shawcroft@gmail.com>2017-06-22 17:38:38 -0700
committerScott Shawcroft <scott.shawcroft@gmail.com>2017-06-22 17:38:38 -0700
commit58a6110be198089d784b5ad3e2ecb611182bd5ea (patch)
tree3f15bebbc4b95584c93ad0f3412b53b7f55c8d5e /icefuzz/make_fanout.py
parented8c4e8c034ffca4424f92fa683ff631c4205b50 (diff)
downloadicestorm-58a6110be198089d784b5ad3e2ecb611182bd5ea.tar.gz
icestorm-58a6110be198089d784b5ad3e2ecb611182bd5ea.tar.bz2
icestorm-58a6110be198089d784b5ad3e2ecb611182bd5ea.zip
Add icefuzz support for the UP5K and rework underlying device specification for more flexibility.
Diffstat (limited to 'icefuzz/make_fanout.py')
-rw-r--r--icefuzz/make_fanout.py18
1 files changed, 7 insertions, 11 deletions
diff --git a/icefuzz/make_fanout.py b/icefuzz/make_fanout.py
index 510fa00..01aa405 100644
--- a/icefuzz/make_fanout.py
+++ b/icefuzz/make_fanout.py
@@ -7,26 +7,22 @@ import os
os.system("rm -rf work_fanout")
os.mkdir("work_fanout")
+
for idx in range(num):
+ output_count = len(pins) - 2
with open("work_fanout/fanout_%02d.v" % idx, "w") as f:
- if os.getenv('ICE384PINS'):
- print("module top(input [1:0] a, output [33:0] y);", file=f)
- print(" assign y = {8{a}};", file=f)
- else:
- print("module top(input [1:0] a, output [63:0] y);", file=f)
- print(" assign y = {32{a}};", file=f)
+ print("module top(input [1:0] a, output [%d:0] y);" % (output_count,), file=f)
+ print(" assign y = {%d{a}};" % (output_count,), file=f)
print("endmodule", file=f)
with open("work_fanout/fanout_%02d.pcf" % idx, "w") as f:
p = np.random.permutation(pins)
- r = 34 if os.getenv('ICE384PINS') else 64
- for i in range(r):
+ for i in range(output_count):
print("set_io y[%d] %s" % (i, p[i]), file=f)
- print("set_io a[0] %s" % p[r], file=f)
- print("set_io a[1] %s" % p[r+1], file=f)
+ print("set_io a[0] %s" % p[output_count], file=f)
+ print("set_io a[1] %s" % p[output_count+1], file=f)
with open("work_fanout/Makefile", "w") as f:
print("all: %s" % " ".join(["fanout_%02d.bin" % i for i in range(num)]), file=f)
for i in range(num):
print("fanout_%02d.bin:" % i, file=f)
print("\t-bash ../icecube.sh fanout_%02d > fanout_%02d.log 2>&1 && rm -rf fanout_%02d.tmp || tail fanout_%02d.log" % (i, i, i, i), file=f)
-