aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--config.mk4
-rw-r--r--icebram/icebram.cc4
-rw-r--r--icetime/icetime.cc8
-rw-r--r--icetime/iceutil.cc2
4 files changed, 9 insertions, 9 deletions
diff --git a/config.mk b/config.mk
index 9cb7793..c7f80a3 100644
--- a/config.mk
+++ b/config.mk
@@ -19,8 +19,8 @@ endif
WARN_LEVEL ?= all
LDLIBS = -lm -lstdc++
-CFLAGS += -MD -O$(OPT_LEVEL) $(DBG_LEVEL) -W$(WARN_LEVEL) -std=$(C_STD) -I$(PREFIX)/include
-CXXFLAGS += -MD -O$(OPT_LEVEL) $(DBG_LEVEL) -W$(WARN_LEVEL) -std=$(CXX_STD) -I$(PREFIX)/include
+CFLAGS += -MD -MP -O$(OPT_LEVEL) $(DBG_LEVEL) -W$(WARN_LEVEL) -std=$(C_STD) -I$(PREFIX)/include
+CXXFLAGS += -MD -MP -O$(OPT_LEVEL) $(DBG_LEVEL) -W$(WARN_LEVEL) -std=$(CXX_STD) -I$(PREFIX)/include
DESTDIR ?=
CHIPDB_SUBDIR ?= $(PROGRAM_PREFIX)icebox
diff --git a/icebram/icebram.cc b/icebram/icebram.cc
index f585fcf..97e6a2c 100644
--- a/icebram/icebram.cc
+++ b/icebram/icebram.cc
@@ -106,7 +106,7 @@ void help(const char *cmd)
printf(" use the same file as <from_hexfile> later.\n");
printf("\n");
printf(" -s <seed>\n");
- printf(" seed random generator with fixed value.\n");
+ printf(" seed random generator with the given value.\n");
printf("\n");
printf(" -v\n");
printf(" verbose output\n");
@@ -131,7 +131,7 @@ int main(int argc, char **argv)
bool verbose = false;
bool generate = false;
bool seed = false;
- uint32_t seed_nr = getpid();
+ uint32_t seed_nr = 0;
int opt;
while ((opt = getopt(argc, argv, "vgs:")) != -1)
diff --git a/icetime/icetime.cc b/icetime/icetime.cc
index 0735b00..9026c7c 100644
--- a/icetime/icetime.cc
+++ b/icetime/icetime.cc
@@ -62,16 +62,16 @@ std::map<int, std::string> net_symbols;
bool get_config_bit(int tile_x, int tile_y, int bit_row, int bit_col)
{
- if (int(config_bits.size()) < tile_x)
+ if (int(config_bits.size()) <= tile_x)
return false;
- if (int(config_bits[tile_x].size()) < tile_y)
+ if (int(config_bits[tile_x].size()) <= tile_y)
return false;
- if (int(config_bits[tile_x][tile_y].size()) < bit_row)
+ if (int(config_bits[tile_x][tile_y].size()) <= bit_row)
return false;
- if (int(config_bits[tile_x][tile_y][bit_row].size()) < bit_col)
+ if (int(config_bits[tile_x][tile_y][bit_row].size()) <= bit_col)
return false;
return config_bits[tile_x][tile_y][bit_row][bit_col];
diff --git a/icetime/iceutil.cc b/icetime/iceutil.cc
index ad8d662..440b9a8 100644
--- a/icetime/iceutil.cc
+++ b/icetime/iceutil.cc
@@ -155,7 +155,7 @@ std::string find_chipdb(std::string config_device)
#else
homepath += getenv("HOME");
#endif
- homepath += std::string(PREFIX + 1) + "/" CHIPDB_SUBDIR "/chipdb-" + config_device + ".txt";
+ homepath += std::string(&PREFIX[1]) + "/" CHIPDB_SUBDIR "/chipdb-" + config_device + ".txt";
if (verbose)
fprintf(stderr, "Looking for chipdb '%s' at %s\n", config_device.c_str(), homepath.c_str());
if (file_test_open(homepath))