aboutsummaryrefslogtreecommitdiffstats
path: root/icefuzz/make_mesh.py
diff options
context:
space:
mode:
Diffstat (limited to 'icefuzz/make_mesh.py')
-rw-r--r--icefuzz/make_mesh.py37
1 files changed, 19 insertions, 18 deletions
diff --git a/icefuzz/make_mesh.py b/icefuzz/make_mesh.py
index a2a7d55..2b50bdf 100644
--- a/icefuzz/make_mesh.py
+++ b/icefuzz/make_mesh.py
@@ -4,29 +4,30 @@ from fuzzconfig import *
import numpy as np
import os
-os.system("rm -rf work_mesh")
-os.mkdir("work_mesh")
+
+device_class = os.getenv("ICEDEVICE")
+
+working_dir = "work_%s_mesh" % (device_class, )
+
+os.system("rm -rf " + working_dir)
+os.mkdir(working_dir)
+
+# This test maps a random set of pins to another random set of outputs.
+
+device_class = os.getenv("ICEDEVICE")
for idx in range(num):
- with open("work_mesh/mesh_%02d.v" % idx, "w") as f:
- if os.getenv('ICE384PINS'):
- print("module top(input [13:0] a, output [13:0] y);", file=f)
- else:
- print("module top(input [39:0] a, output [39:0] y);", file=f)
+ io_count = len(pins) // 2
+ with open(working_dir + "/mesh_%02d.v" % idx, "w") as f:
+ print("module top(input [%d:0] a, output [%d:0] y);" % (io_count, io_count), file=f)
print(" assign y = a;", file=f)
print("endmodule", file=f)
- with open("work_mesh/mesh_%02d.pcf" % idx, "w") as f:
+ with open(working_dir + "/mesh_%02d.pcf" % idx, "w") as f:
p = np.random.permutation(pins)
- if os.getenv('ICE384PINS'): r = 14
- else: r = 40
- for i in range(r):
+ for i in range(io_count):
print("set_io a[%d] %s" % (i, p[i]), file=f)
- for i in range(r):
- print("set_io y[%d] %s" % (i, p[r+i]), file=f)
+ for i in range(io_count):
+ print("set_io y[%d] %s" % (i, p[io_count+i]), file=f)
-with open("work_mesh/Makefile", "w") as f:
- print("all: %s" % " ".join(["mesh_%02d.bin" % i for i in range(num)]), file=f)
- for i in range(num):
- print("mesh_%02d.bin:" % i, file=f)
- print("\t-bash ../icecube.sh mesh_%02d > mesh_%02d.log 2>&1 && rm -rf mesh_%02d.tmp || tail mesh_%02d.log" % (i, i, i, i), file=f)
+output_makefile(working_dir, "mesh")