aboutsummaryrefslogtreecommitdiffstats
path: root/icepll/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'icepll/Makefile')
-rw-r--r--icepll/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/icepll/Makefile b/icepll/Makefile
index b47de3e..e0badf6 100644
--- a/icepll/Makefile
+++ b/icepll/Makefile
@@ -2,6 +2,10 @@ include ../config.mk
LDLIBS = -lm -lstdc++
CXXFLAGS = -MD -O0 -ggdb -Wall -std=c++11 -I/usr/local/include
+ifeq ($(STATIC),1)
+LDFLAGS += -static
+endif
+
all: icepll$(EXE)
icepll$(EXE): icepll.o