aboutsummaryrefslogtreecommitdiffstats
path: root/icepll/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'icepll/Makefile')
-rw-r--r--icepll/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/icepll/Makefile b/icepll/Makefile
new file mode 100644
index 0000000..9a190f6
--- /dev/null
+++ b/icepll/Makefile
@@ -0,0 +1,22 @@
+include ../config.mk
+LDLIBS = -lm -lstdc++
+CXXFLAGS = -MD -O0 -ggdb -Wall -std=c++11 -I/usr/local/include
+
+all: icepll
+
+icepll: icepll.o
+
+install: all
+ mkdir -p $(DESTDIR)$(PREFIX)/bin
+ cp icepll $(DESTDIR)$(PREFIX)/bin/icepll
+
+uninstall:
+ rm -f $(DESTDIR)$(PREFIX)/bin/icepll
+
+clean:
+ rm -f icepll *.o *.d
+
+-include *.d
+
+.PHONY: all install uninstall clean
+