aboutsummaryrefslogtreecommitdiffstats
path: root/iceprog
diff options
context:
space:
mode:
Diffstat (limited to 'iceprog')
-rw-r--r--iceprog/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/iceprog/Makefile b/iceprog/Makefile
index 5b9f790..fdeadf5 100644
--- a/iceprog/Makefile
+++ b/iceprog/Makefile
@@ -1,6 +1,13 @@
include ../config.mk
-LDLIBS = -L/usr/local/lib -lm
-CFLAGS = -MD -O0 -ggdb -Wall -std=c99 -I/usr/local/include
+
+UNAME := $(shell uname -s)
+ifneq ($(UNAME),Darwin)
+ LDLIBS = -L/usr/local/lib -lm
+ CFLAGS = -MD -O0 -ggdb -Wall -std=c99 -I/usr/local/include
+else
+ LDLIBS = -L/usr/local/lib -L/opt/local/lib -lftdi -lm
+ CFLAGS = -MD -O0 -ggdb -Wall -std=c99 -I/usr/local/include -I/opt/local/include/
+endif
ifeq ($(STATIC),1)
LDFLAGS += -static