aboutsummaryrefslogtreecommitdiffstats
path: root/icetime/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'icetime/Makefile')
-rw-r--r--icetime/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/icetime/Makefile b/icetime/Makefile
index 2eef844..e93eaa2 100644
--- a/icetime/Makefile
+++ b/icetime/Makefile
@@ -14,8 +14,19 @@ install: all
uninstall:
rm -f $(DESTDIR)/bin/icetime
+
+# View timing netlist:
+# yosys -qp 'read_verilog -lib cells.v; prep; show' test0_ref.v
+
+test0 test1 test2 test3 test4 test5 test6 test7 test8 test9: icetime
+ python3 mktest.py $@
+ ./icetime -P tq144 -p $@.pcf $@.txt $@_out.v
+
+mktest: test0 test1 test2 test3 test4 test5 test6 test7 test8 test9
+
clean:
rm -f icetime
+ rm -f test[0-9]*
rm -f *.o *.d
-include *.d