aboutsummaryrefslogtreecommitdiffstats
path: root/icetime/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'icetime/Makefile')
-rw-r--r--icetime/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/icetime/Makefile b/icetime/Makefile
new file mode 100644
index 0000000..2eef844
--- /dev/null
+++ b/icetime/Makefile
@@ -0,0 +1,24 @@
+# CXX = clang
+LDLIBS = -lm -lstdc++
+CXXFLAGS = -MD -O0 -ggdb -Wall -std=c++11 -I/usr/local/include
+CC = $(CXX)
+DESTDIR = /usr/local
+
+all: icetime
+
+icetime: icetime.o
+
+install: all
+ cp icetime $(DESTDIR)/bin/icetime
+
+uninstall:
+ rm -f $(DESTDIR)/bin/icetime
+
+clean:
+ rm -f icetime
+ rm -f *.o *.d
+
+-include *.d
+
+.PHONY: all install uninstall clean
+