aboutsummaryrefslogtreecommitdiffstats
path: root/icetime/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'icetime/Makefile')
-rw-r--r--icetime/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/icetime/Makefile b/icetime/Makefile
index 5d0ecee..76e8e9b 100644
--- a/icetime/Makefile
+++ b/icetime/Makefile
@@ -28,14 +28,14 @@ run0 run1 run2 run3 run4 run5 run6 run7 run8 run9: icetime
./icetime -P tq144 -p $(subst run,test,$@).pcf $(subst run,test,$@).txt $(subst run,test,$@)_out.v
show0 show1 show2 show3 show4 show5 show6 show7 show8 show9:
- yosys -p ':equiv_purge; opt_clean -purge; show' $(subst show,test,$@).il
+ # yosys -p 'equiv_purge; opt_clean -purge; show' $(subst show,test,$@).il
+ yosys -p 'equiv_mark; opt_clean -purge; show -color orange a:equiv_region!=0' $(subst show,test,$@).il
test: test0 test1 test2 test3 test4 test5 test6 test7 test8 test9
clean:
- rm -f icetime
- rm -f test[0-9]*
- rm -f *.o *.d
+ rm -f icetime *.o *.d
+ rm -rf test[0-9]*
-include *.d