aboutsummaryrefslogtreecommitdiffstats
path: root/icetime
diff options
context:
space:
mode:
Diffstat (limited to 'icetime')
-rw-r--r--icetime/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/icetime/Makefile b/icetime/Makefile
index 6355f06..c56002b 100644
--- a/icetime/Makefile
+++ b/icetime/Makefile
@@ -2,6 +2,10 @@ include ../config.mk
LDLIBS = -lm -lstdc++
CXXFLAGS = -MD -O0 -ggdb -Wall -std=c++11 -I/usr/local/include -DPREFIX='"$(PREFIX)"'
+ifeq ($(STATIC),1)
+LDFLAGS += -static
+endif
+
all: icetime$(EXE)
icetime$(EXE): icetime.o