aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--ice40/regressions/Makefile4
-rw-r--r--ice40/regressions/issue0084/mlaccel.sh2
-rw-r--r--ice40/regressions/issue0090/conn-crash.sh2
-rw-r--r--ice40/regressions/issue0120/top.sh2
4 files changed, 5 insertions, 5 deletions
diff --git a/ice40/regressions/Makefile b/ice40/regressions/Makefile
index 2e961fe..8793053 100644
--- a/ice40/regressions/Makefile
+++ b/ice40/regressions/Makefile
@@ -20,7 +20,7 @@ ifeq ($(wildcard $(NPNR)),)
endif
%.json: %.json.gz
- gzip -dk $<
+ gzip -fdk $<
$(JSON_OUTPUT): %_postpnr.v: %.json $(wildcard %.pcf) $(wildcard %.npnr) $(NPNR)
$(NPNR) --json $*.json --asc $*.asc $(if $(wildcard $*.pcf),--pcf $*.pcf,) $(if $(wildcard $*.npnr),$(shell cat $*.npnr),) > /dev/null 2>&1 || test -f $(dir $*)WAIVE
@@ -31,7 +31,7 @@ $(JSON_OUTPUT): %_postpnr.v: %.json $(wildcard %.pcf) $(wildcard %.npnr) $(NPNR)
fi
$(SH_OUTPUT): %_postpnr.v: %.sh $(NPNR)
- gzip -dk $*.json.gz
+ gzip -fdk $*.json.gz
cd $(dir $@) && NPNR=$(NPNR) bash $(notdir $*.sh) > /dev/null 2>&1
if [ -f "$*.asc" ]; then \
icebox_vlog $*.asc > $@; \
diff --git a/ice40/regressions/issue0084/mlaccel.sh b/ice40/regressions/issue0084/mlaccel.sh
index 76dfd09..4a55275 100644
--- a/ice40/regressions/issue0084/mlaccel.sh
+++ b/ice40/regressions/issue0084/mlaccel.sh
@@ -1,3 +1,3 @@
:> mlaccel.log
${NPNR} --json mlaccel.json --asc mlaccel.asc --pcf mlaccel.pcf `cat mlaccel.npnr` > mlaccel.log 2>&1 || true
-grep "^ERROR: PACKAGE_PIN of SB_IO 'qpi_in_buf\\[[01]\\]' connected to more than a single top level IO.$" mlaccel.log
+grep "^ERROR: PACKAGE_PIN of SB_IO 'qpi_i[on]_buf\\[[01]\\]' connected to more than a single top level IO.$" mlaccel.log
diff --git a/ice40/regressions/issue0090/conn-crash.sh b/ice40/regressions/issue0090/conn-crash.sh
index 57a20ef..88c4df8 100644
--- a/ice40/regressions/issue0090/conn-crash.sh
+++ b/ice40/regressions/issue0090/conn-crash.sh
@@ -1,3 +1,3 @@
:> conn-crash.log
${NPNR} --json conn-crash.json --asc conn-crash.asc --pcf conn-crash.pcf `cat conn-crash.npnr` > conn-crash.log 2>&1 || true
-grep "^ERROR: Cell 'clk12\$sb_io' cannot be bound to bel 'X12/Y31/io1' since it is already bound to cell 'sevenseg_segment2\$sb_io'$" conn-crash.log
+grep "^ERROR: Cell 'sevenseg_segment2\$sb_io' cannot be bound to bel 'X12/Y31/io1' since it is already bound to cell 'clk12\$sb_io'$" conn-crash.log
diff --git a/ice40/regressions/issue0120/top.sh b/ice40/regressions/issue0120/top.sh
index 171680f..88ca41d 100644
--- a/ice40/regressions/issue0120/top.sh
+++ b/ice40/regressions/issue0120/top.sh
@@ -1,3 +1,3 @@
:> top.log
${NPNR} --json top.json --asc top.asc --pcf top.pcf `cat top.npnr` > top.log 2>&1 || true
-grep "^ERROR: PACKAGE_PIN of SB_IO 'SB_IO' connected to more than a single top level IO.$" top.log
+grep "^ERROR: PACKAGE_PIN of SB_IO 'SB_IO_1' connected to more than a single top level IO.$" top.log