aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Shah <dave@ds0.me>2019-11-12 11:33:49 +0000
committerDavid Shah <dave@ds0.me>2019-12-27 10:44:29 +0000
commitfffc3b844730d1241d0056f989b3a9492d62005c (patch)
tree61d2fe1cd37f5675f352e9862d8b18775225642f /CMakeLists.txt
parentfa7317f5940841e7ff56fed748c4f1f4117baae4 (diff)
downloadnextpnr-fffc3b844730d1241d0056f989b3a9492d62005c.tar.gz
nextpnr-fffc3b844730d1241d0056f989b3a9492d62005c.tar.bz2
nextpnr-fffc3b844730d1241d0056f989b3a9492d62005c.zip
frontend/base: Top module handling
Signed-off-by: David Shah <dave@ds0.me>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9af4bb6c..e8fa4ec0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -191,7 +191,7 @@ if (BUILD_PYTHON)
endif ()
endif()
-include_directories(common/ json/ ${Boost_INCLUDE_DIRS} ${PYTHON_INCLUDE_DIRS})
+include_directories(common/ json/ frontend/ ${Boost_INCLUDE_DIRS} ${PYTHON_INCLUDE_DIRS})
if(BUILD_HEAP)
find_package (Eigen3 REQUIRED NO_MODULE)
@@ -202,7 +202,9 @@ endif()
aux_source_directory(common/ COMMON_SRC_FILES)
aux_source_directory(json/ JSON_PARSER_FILES)
-set(COMMON_FILES ${COMMON_SRC_FILES} ${JSON_PARSER_FILES})
+aux_source_directory(frontend/ FRONTEND_FILES)
+
+set(COMMON_FILES ${COMMON_SRC_FILES} ${JSON_PARSER_FILES} ${FRONTEND_FILES})
set(CMAKE_BUILD_TYPE Release)
if(MINGW)