aboutsummaryrefslogtreecommitdiffstats
path: root/3rdparty/pybind11/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to '3rdparty/pybind11/pyproject.toml')
-rw-r--r--3rdparty/pybind11/pyproject.toml60
1 files changed, 59 insertions, 1 deletions
diff --git a/3rdparty/pybind11/pyproject.toml b/3rdparty/pybind11/pyproject.toml
index 5c9d1535..3ba1b4b2 100644
--- a/3rdparty/pybind11/pyproject.toml
+++ b/3rdparty/pybind11/pyproject.toml
@@ -1,3 +1,61 @@
[build-system]
-requires = ["setuptools>=42", "wheel", "cmake>=3.18", "ninja"]
+requires = ["setuptools>=42", "cmake>=3.18", "ninja"]
build-backend = "setuptools.build_meta"
+
+[tool.check-manifest]
+ignore = [
+ "tests/**",
+ "docs/**",
+ "tools/**",
+ "include/**",
+ ".*",
+ "pybind11/include/**",
+ "pybind11/share/**",
+ "CMakeLists.txt",
+ "noxfile.py",
+]
+
+[tool.isort]
+# Needs the compiled .so modules and env.py from tests
+known_first_party = "env,pybind11_cross_module_tests,pybind11_tests,"
+# For black compatibility
+profile = "black"
+
+[tool.mypy]
+files = ["pybind11"]
+python_version = "3.6"
+strict = true
+show_error_codes = true
+enable_error_code = ["ignore-without-code", "redundant-expr", "truthy-bool"]
+warn_unreachable = true
+
+[[tool.mypy.overrides]]
+module = ["ghapi.*", "setuptools.*"]
+ignore_missing_imports = true
+
+
+[tool.pytest.ini_options]
+minversion = "6.0"
+addopts = ["-ra", "--showlocals", "--strict-markers", "--strict-config"]
+xfail_strict = true
+filterwarnings = ["error"]
+log_cli_level = "info"
+testpaths = [
+ "tests",
+]
+timeout=300
+
+
+[tool.pylint]
+master.py-version = "3.6"
+reports.output-format = "colorized"
+messages_control.disable = [
+ "design",
+ "fixme",
+ "imports",
+ "line-too-long",
+ "imports",
+ "invalid-name",
+ "protected-access",
+ "missing-module-docstring",
+]