aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt2
-rw-r--r--common/kernel/report.cc5
-rw-r--r--nexus/fasm.cc5
3 files changed, 3 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3120cf40..e0001447 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 3.5)
+cmake_minimum_required(VERSION 3.13)
project(nextpnr CXX C)
# Allow family.cmake add additional dependencies to gui_${family}.
diff --git a/common/kernel/report.cc b/common/kernel/report.cc
index 98ff14fb..8f583b33 100644
--- a/common/kernel/report.cc
+++ b/common/kernel/report.cc
@@ -131,11 +131,6 @@ static Json::array report_detailed_net_timings(const Context *ctx)
Json::array endpointsJson;
for (const auto &sink_timing : it.second) {
-
- // FIXME: Is it possible that there are multiple different start
- // events for a single net? It has a single driver
- NPNR_ASSERT(sink_timing.clock_pair.start == start);
-
auto endpointJson = Json::object({{"cell", sink_timing.cell_port.first.c_str(ctx)},
{"port", sink_timing.cell_port.second.c_str(ctx)},
{"event", clock_event_name(ctx, sink_timing.clock_pair.end)},
diff --git a/nexus/fasm.cc b/nexus/fasm.cc
index 3ed5785e..de03fb82 100644
--- a/nexus/fasm.cc
+++ b/nexus/fasm.cc
@@ -533,11 +533,10 @@ struct NexusFasmWriter
void write_dcc(const CellInfo *cell)
{
BelId bel = cell->bel;
- push_tile(bel.tile);
- push_belname(bel);
+ push_bel(bel);
write_bit("DCCEN.1"); // Explicit DCC cell implies a clock buffer
write_cell_muxes(cell);
- pop(2);
+ pop();
}
// Write config for DCS
void write_dcs(const CellInfo *cell)