aboutsummaryrefslogtreecommitdiffstats
path: root/fpga_interchange/examples/archcheck/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'fpga_interchange/examples/archcheck/Makefile')
-rw-r--r--fpga_interchange/examples/archcheck/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/fpga_interchange/examples/archcheck/Makefile b/fpga_interchange/examples/archcheck/Makefile
index cf82013b..02e1c08e 100644
--- a/fpga_interchange/examples/archcheck/Makefile
+++ b/fpga_interchange/examples/archcheck/Makefile
@@ -13,4 +13,11 @@ check: check_test_data
check_test_data:
$(NEXTPNR_BIN) \
--chipdb $(BBA_PATH) \
+ --package $(PACKAGE) \
+ --run $(NEXTPNR_PATH)/python/check_arch_api.py
+
+debug_check_test_data:
+ gdb --args $(NEXTPNR_BIN) \
+ --chipdb $(BBA_PATH) \
+ --package $(PACKAGE) \
--run $(NEXTPNR_PATH)/python/check_arch_api.py