aboutsummaryrefslogtreecommitdiffstats
path: root/fpga_interchange/examples/archcheck/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'fpga_interchange/examples/archcheck/Makefile')
-rw-r--r--fpga_interchange/examples/archcheck/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/fpga_interchange/examples/archcheck/Makefile b/fpga_interchange/examples/archcheck/Makefile
index 8984e1b4..cf82013b 100644
--- a/fpga_interchange/examples/archcheck/Makefile
+++ b/fpga_interchange/examples/archcheck/Makefile
@@ -1,16 +1,16 @@
-NEXTPNR_PATH := $(shell echo ~/cat_x/nextpnr)
-NEXTPNR_BIN := $(NEXTPNR_PATH)/build/nextpnr-fpga_interchange
-BBA_PATH := $(NEXTPNR_PATH)/build/test.bin
+include ../common.mk
PACKAGE := csg324
-.PHONY:
+.PHONY: check check_test_data
-check:
+check: check_test_data
$(NEXTPNR_BIN) \
--chipdb $(BBA_PATH) \
--package $(PACKAGE) \
--test
+
+check_test_data:
$(NEXTPNR_BIN) \
--chipdb $(BBA_PATH) \
--run $(NEXTPNR_PATH)/python/check_arch_api.py