aboutsummaryrefslogtreecommitdiffstats
path: root/fpga_interchange/examples/tests/counter
diff options
context:
space:
mode:
Diffstat (limited to 'fpga_interchange/examples/tests/counter')
-rw-r--r--fpga_interchange/examples/tests/counter/CMakeLists.txt3
-rw-r--r--fpga_interchange/examples/tests/counter/zybo.xdc14
2 files changed, 16 insertions, 1 deletions
diff --git a/fpga_interchange/examples/tests/counter/CMakeLists.txt b/fpga_interchange/examples/tests/counter/CMakeLists.txt
index 2f1509c2..38c104ff 100644
--- a/fpga_interchange/examples/tests/counter/CMakeLists.txt
+++ b/fpga_interchange/examples/tests/counter/CMakeLists.txt
@@ -1,8 +1,9 @@
add_interchange_group_test(
name counter
family ${family}
- board_list basys3 arty35t arty100t
+ board_list basys3 arty35t arty100t zybo
tcl run.tcl
sources counter.v
techmap ../../remap.v
+ output_fasm
)
diff --git a/fpga_interchange/examples/tests/counter/zybo.xdc b/fpga_interchange/examples/tests/counter/zybo.xdc
new file mode 100644
index 00000000..e7764d52
--- /dev/null
+++ b/fpga_interchange/examples/tests/counter/zybo.xdc
@@ -0,0 +1,14 @@
+# zybo board
+set_property PACKAGE_PIN K17 [get_ports clk]
+set_property PACKAGE_PIN K18 [get_ports rst]
+set_property PACKAGE_PIN M14 [get_ports io_led[4]]
+set_property PACKAGE_PIN M15 [get_ports io_led[5]]
+set_property PACKAGE_PIN G14 [get_ports io_led[6]]
+set_property PACKAGE_PIN D18 [get_ports io_led[7]]
+
+set_property IOSTANDARD LVCMOS33 [get_ports clk]
+set_property IOSTANDARD LVCMOS33 [get_ports rst]
+set_property IOSTANDARD LVCMOS33 [get_ports io_led[4]]
+set_property IOSTANDARD LVCMOS33 [get_ports io_led[5]]
+set_property IOSTANDARD LVCMOS33 [get_ports io_led[6]]
+set_property IOSTANDARD LVCMOS33 [get_ports io_led[7]]