aboutsummaryrefslogtreecommitdiffstats
path: root/gui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gui/CMakeLists.txt')
-rw-r--r--gui/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/gui/CMakeLists.txt b/gui/CMakeLists.txt
index e692eee9..21d0c1e0 100644
--- a/gui/CMakeLists.txt
+++ b/gui/CMakeLists.txt
@@ -39,6 +39,11 @@ if (BUILD_PYTHON)
endif()
target_compile_definitions(gui_${family} PRIVATE NEXTPNR_NAMESPACE=nextpnr_${family} ARCH_${ufamily} ARCHNAME=${family} QT_NO_KEYWORDS)
+
+if (USE_ABSEIL)
+ target_compile_definitions(gui_${family} PRIVATE USE_ABSEIL)
+endif()
+
target_link_libraries(gui_${family} Qt5::Widgets)
foreach(lib_dep ${EXTRA_LIB_DEPS})