aboutsummaryrefslogtreecommitdiffstats
path: root/passes/cmds/Makefile.inc
diff options
context:
space:
mode:
authorwhitequark <whitequark@whitequark.org>2019-01-07 00:11:49 +0000
committerwhitequark <whitequark@whitequark.org>2019-01-07 03:13:19 +0000
commita342d6db49b812efa1457f39dc9713bcda3d54ce (patch)
tree4b58994e556208c4722aab1fbf2eb8176dcecd35 /passes/cmds/Makefile.inc
parenta2c51d50fb5a94967a204913404b71c7af0b59e2 (diff)
downloadyosys-a342d6db49b812efa1457f39dc9713bcda3d54ce.tar.gz
yosys-a342d6db49b812efa1457f39dc9713bcda3d54ce.tar.bz2
yosys-a342d6db49b812efa1457f39dc9713bcda3d54ce.zip
bugpoint: new pass.
A typical use of `bugpoint` would involve a script with a pass under test, e.g.: flowmap -relax -optarea 100 and would be invoked as: bugpoint -yosys ./yosys -script flowmap.ys -clean -cells This replaces the current design with the minimal design that still crashes the `flowmap.ys` script. `bugpoint` can also be used to perform generic design minimization using `select`, e.g. the following script: select i:* %x t:$_MUX_ %i -assert-max 0 would remove all parts of the design except for an unbroken path from an input to an output port that goes through exactly one $_MUX_ cell. (The condition is inverted.)
Diffstat (limited to 'passes/cmds/Makefile.inc')
-rw-r--r--passes/cmds/Makefile.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/passes/cmds/Makefile.inc b/passes/cmds/Makefile.inc
index 44a83b2b9..c8067a8be 100644
--- a/passes/cmds/Makefile.inc
+++ b/passes/cmds/Makefile.inc
@@ -29,4 +29,4 @@ OBJS += passes/cmds/chformal.o
OBJS += passes/cmds/chtype.o
OBJS += passes/cmds/blackbox.o
OBJS += passes/cmds/ltp.o
-
+OBJS += passes/cmds/bugpoint.o