aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--kernel/log.h5
-rw-r--r--techlibs/common/simlib.v6
3 files changed, 8 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index e03a873b4..78526d5ef 100644
--- a/Makefile
+++ b/Makefile
@@ -141,7 +141,7 @@ LDLIBS += -lrt
endif
endif
-YOSYS_VER := 0.22+57
+YOSYS_VER := 0.22+62
# Note: We arrange for .gitcommit to contain the (short) commit hash in
# tarballs generated with git-archive(1) using .gitattributes. The git repo
diff --git a/kernel/log.h b/kernel/log.h
index 8ef6e6d0e..822816cb4 100644
--- a/kernel/log.h
+++ b/kernel/log.h
@@ -393,6 +393,11 @@ void log_dump_val_worker(RTLIL::IdString v);
void log_dump_val_worker(RTLIL::SigSpec v);
void log_dump_val_worker(RTLIL::State v);
+template<typename K, typename T, typename OPS> static inline void log_dump_val_worker(dict<K, T, OPS> &v);
+template<typename K, typename OPS> static inline void log_dump_val_worker(pool<K, OPS> &v);
+template<typename K> static inline void log_dump_val_worker(std::vector<K> &v);
+template<typename T> static inline void log_dump_val_worker(T *ptr);
+
template<typename K, typename T, typename OPS>
static inline void log_dump_val_worker(dict<K, T, OPS> &v) {
log("{");
diff --git a/techlibs/common/simlib.v b/techlibs/common/simlib.v
index 2fd75372d..e64697efb 100644
--- a/techlibs/common/simlib.v
+++ b/techlibs/common/simlib.v
@@ -1279,11 +1279,9 @@ parameter WIDTH = 0;
input [WIDTH-1:0] A, B;
input S;
-output reg [WIDTH-1:0] Y;
+output [WIDTH-1:0] Y;
-always @* begin
- assign Y = S ? B : A;
-end
+assign Y = S ? B : A;
endmodule