aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--passes/techmap/dfflegalize.cc4
-rwxr-xr-xtests/tools/vcdcd.pl6
3 files changed, 4 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index 1b9a65dbe..423edc07d 100644
--- a/Makefile
+++ b/Makefile
@@ -127,7 +127,7 @@ LDFLAGS += -rdynamic
LDLIBS += -lrt
endif
-YOSYS_VER := 0.10+28
+YOSYS_VER := 0.10+30
GIT_REV := $(shell git -C $(YOSYS_SRC) rev-parse --short HEAD 2> /dev/null || echo UNKNOWN)
OBJS = kernel/version_$(GIT_REV).o
diff --git a/passes/techmap/dfflegalize.cc b/passes/techmap/dfflegalize.cc
index c1e7e557d..5210d01eb 100644
--- a/passes/techmap/dfflegalize.cc
+++ b/passes/techmap/dfflegalize.cc
@@ -718,10 +718,6 @@ flip_dqisr:;
goto error;
}
- if (!(supported_dlatch & ~INIT_X)) {
- reason = "initialized dlatch are not supported";
- goto error;
- }
// If we got here, initialized dlatch is supported, but not this
// particular reset+init combination (nor its negation).
// The only hope left is breaking down to adff + dff + dlatch + mux.
diff --git a/tests/tools/vcdcd.pl b/tests/tools/vcdcd.pl
index 58a92b44d..0f33371fb 100755
--- a/tests/tools/vcdcd.pl
+++ b/tests/tools/vcdcd.pl
@@ -11,7 +11,7 @@ $| = 1;
my $opt_width = 0;
my $opt_delay = 0;
-while (1)
+while ($#ARGV >= 0)
{
if ($ARGV[0] eq '-w') {
$opt_width = +$ARGV[1];
@@ -74,10 +74,10 @@ for my $net (sort keys %gold_signals_hash) {
# next unless $net eq "tst_bench_top.i2c_top.byte_controller.bit_controller.cnt";
my %orig_net_names;
print "common signal: $net";
- for my $fullname (keys $gold_signals_hash{$net}) {
+ for my $fullname (keys %{$gold_signals_hash{$net}}) {
$orig_net_names{$fullname} = 1;
}
- for my $fullname (keys $gate_signals_hash{$net}) {
+ for my $fullname (keys %{$gate_signals_hash{$net}}) {
$orig_net_names{$fullname} = 1;
}
for my $net (sort keys %orig_net_names) {