aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGELOG12
-rw-r--r--Makefile2
2 files changed, 13 insertions, 1 deletions
diff --git a/CHANGELOG b/CHANGELOG
index dcb88d6fe..0b1bbc733 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -5,6 +5,11 @@ List of major changes and improvements between releases
Yosys 0.14 .. Yosys 0.14-dev
--------------------------
+ * Various
+ - clk2fflogic: nice names for autogenerated signals
+ - simulation include support for all flip-flop types.
+ - Added AIGER witness file co-simulation.
+
* Verilog
- Fixed evaluation of constant functions with variables or arguments with
reversed dimensions
@@ -14,6 +19,13 @@ Yosys 0.14 .. Yosys 0.14-dev
* SystemVerilog
- Added support for accessing whole sub-structures in expressions
+
+ * New commands and options
+ - Added glift command, used to create gate-level information flow tracking
+ (GLIFT) models by the "constructive mapping" approach
+
+ * Verific support
+ - Ability to override default parser mode for verific -f command.
Yosys 0.13 .. Yosys 0.14
--------------------------
diff --git a/Makefile b/Makefile
index 61e8bbe5e..979db4d1b 100644
--- a/Makefile
+++ b/Makefile
@@ -129,7 +129,7 @@ LDFLAGS += -rdynamic
LDLIBS += -lrt
endif
-YOSYS_VER := 0.14+60
+YOSYS_VER := 0.14+67
GIT_REV := $(shell git -C $(YOSYS_SRC) rev-parse --short HEAD 2> /dev/null || echo UNKNOWN)
OBJS = kernel/version_$(GIT_REV).o