aboutsummaryrefslogtreecommitdiffstats
path: root/docs/source/CHAPTER_Prog.rst
diff options
context:
space:
mode:
Diffstat (limited to 'docs/source/CHAPTER_Prog.rst')
-rw-r--r--docs/source/CHAPTER_Prog.rst46
1 files changed, 46 insertions, 0 deletions
diff --git a/docs/source/CHAPTER_Prog.rst b/docs/source/CHAPTER_Prog.rst
new file mode 100644
index 000000000..23aeed5a5
--- /dev/null
+++ b/docs/source/CHAPTER_Prog.rst
@@ -0,0 +1,46 @@
+.. _chapter:prog:
+
+Programming Yosys extensions
+============================
+
+This chapter contains some bits and pieces of information about
+programming yosys extensions. Also consult the section on programming in
+the "Yosys Presentation" (can be downloaded from the Yosys website as
+PDF) and don't be afraid to ask questions on the YosysHQ Slack.
+
+Guidelines
+----------
+
+The guidelines directory contains notes on various aspects of Yosys
+development. The files GettingStarted and CodingStyle may be of
+particular interest, and are reproduced here.
+
+.. literalinclude:: temp/GettingStarted
+ :language: none
+ :caption: guidelines/GettingStarted
+
+.. literalinclude:: temp/CodingStyle
+ :language: none
+ :caption: guidelines/CodingStyle
+
+The "stubsnets" example module
+------------------------------
+
+The following is the complete code of the "stubsnets" example module. It
+is included in the Yosys source distribution as
+docs/source/CHAPTER_Prog/stubnets.cc.
+
+.. literalinclude:: CHAPTER_Prog/stubnets.cc
+ :language: c++
+ :linenos:
+ :caption: docs/source/CHAPTER_Prog/stubnets.cc
+
+.. literalinclude:: CHAPTER_Prog/Makefile
+ :language: makefile
+ :linenos:
+ :caption: docs/source/CHAPTER_Prog/Makefile
+
+.. literalinclude:: CHAPTER_Prog/test.v
+ :language: verilog
+ :linenos:
+ :caption: docs/source/CHAPTER_Prog/test.v