aboutsummaryrefslogtreecommitdiffstats
path: root/passes/techmap
diff options
context:
space:
mode:
Diffstat (limited to 'passes/techmap')
-rw-r--r--passes/techmap/Makefile.inc9
1 files changed, 4 insertions, 5 deletions
diff --git a/passes/techmap/Makefile.inc b/passes/techmap/Makefile.inc
index b83ab8495..85d580ce8 100644
--- a/passes/techmap/Makefile.inc
+++ b/passes/techmap/Makefile.inc
@@ -10,12 +10,11 @@ OBJS += passes/techmap/extract.o
GENFILES += passes/techmap/stdcells.inc
passes/techmap/stdcells.inc: techlibs/common/stdcells.v
- echo "// autogenerated from $<\n" > $@.new
+ echo "// autogenerated from $<" > $@.new
echo "static char stdcells_code[] = {" >> $@.new
- for c in `od -v -td1 -An $<` ; do echo " $$c," >> $@.new ; done
- echo " 0 };" >> $@.new
- fmt $@.new > $@
- rm -f $@.new
+ od -v -td1 -An $< | $(SED) -e 's/[0-9][0-9]*/&,/g' >> $@.new
+ echo "0};" >> $@.new
+ mv $@.new $@
passes/techmap/techmap.o: passes/techmap/stdcells.inc