aboutsummaryrefslogtreecommitdiffstats
path: root/tests/simple_abc9/run-test.sh
diff options
context:
space:
mode:
Diffstat (limited to 'tests/simple_abc9/run-test.sh')
-rwxr-xr-xtests/simple_abc9/run-test.sh32
1 files changed, 32 insertions, 0 deletions
diff --git a/tests/simple_abc9/run-test.sh b/tests/simple_abc9/run-test.sh
new file mode 100755
index 000000000..32d7a80ca
--- /dev/null
+++ b/tests/simple_abc9/run-test.sh
@@ -0,0 +1,32 @@
+#!/bin/bash
+
+OPTIND=1
+seed="" # default to no seed specified
+while getopts "S:" opt
+do
+ case "$opt" in
+ S) arg="${OPTARG#"${OPTARG%%[![:space:]]*}"}" # remove leading space
+ seed="SEED=$arg" ;;
+ esac
+done
+shift "$((OPTIND-1))"
+
+# check for Icarus Verilog
+if ! command -v iverilog > /dev/null ; then
+ echo "$0: Error: Icarus Verilog 'iverilog' not found."
+ exit 1
+fi
+
+cp ../simple/*.v .
+cp ../simple/*.sv .
+DOLLAR='?'
+exec ${MAKE:-make} -f ../tools/autotest.mk $seed *.v *.sv EXTRA_FLAGS="-n 300 -p '\
+ hierarchy; \
+ synth -run coarse; \
+ opt -full; \
+ techmap; \
+ abc9 -lut 4 -box ../abc.box; \
+ clean; \
+ check -assert; \
+ select -assert-none t:${DOLLAR}_NOT_ t:${DOLLAR}_AND_ %%; \
+ setattr -mod -unset whitebox'"