summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-11-27 18:42:45 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-11-27 18:42:45 +0000
commit7196f5d7c8ec0de8ae06cf664adbf8cdda2c594d (patch)
treeb1a51ef8b44b9a2059005fc57f9a40a112d00d77
parent0588d13a3e87cbc746dde4facc60d1baa9abb3df (diff)
downloadmaster-31e0f0ae-7196f5d7c8ec0de8ae06cf664adbf8cdda2c594d.tar.gz
master-31e0f0ae-7196f5d7c8ec0de8ae06cf664adbf8cdda2c594d.tar.bz2
master-31e0f0ae-7196f5d7c8ec0de8ae06cf664adbf8cdda2c594d.zip
image.mk: don't squash file permissions in JFFS2 images
Currently we call mkfs.jffs2 --squash, which will change both file permissions and owners. If we have some file with suid bits, it will clear these bits. Thus it's enough to just squash file owners, by replacing that argument to --squash-uids. Signed-off-by: Jonh Wendell <jonh.wendell@oiwifi.com.br> Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 34397
-rw-r--r--include/image.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index 1977fc84c0..10850a6327 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -18,9 +18,9 @@ KDIR=$(KERNEL_BUILD_DIR)
IMG_PREFIX:=openwrt-$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))
ifneq ($(CONFIG_BIG_ENDIAN),)
- JFFS2OPTS := --pad --big-endian --squash -v
+ JFFS2OPTS := --pad --big-endian --squash-uids -v
else
- JFFS2OPTS := --pad --little-endian --squash -v
+ JFFS2OPTS := --pad --little-endian --squash-uids -v
endif
ifeq ($(CONFIG_JFFS2_RTIME),y)