summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-06-21 16:53:15 +0000
committerJohn Crispin <john@openwrt.org>2013-06-21 16:53:15 +0000
commit39df8d1a4573e15bd3bd46fed48fa0d0769a2bdc (patch)
tree206fb88024c4b27e34908427458ac4057c89fd68
parent2be717560ac9bf55cf94253d16c1d271d71c5df6 (diff)
downloadmaster-31e0f0ae-39df8d1a4573e15bd3bd46fed48fa0d0769a2bdc.tar.gz
master-31e0f0ae-39df8d1a4573e15bd3bd46fed48fa0d0769a2bdc.tar.bz2
master-31e0f0ae-39df8d1a4573e15bd3bd46fed48fa0d0769a2bdc.zip
brcm47xx: dont manually insmod switch drivers
Signed-off-by: John Crispin <bloic@openwrt.org> SVN-Revision: 36993
-rw-r--r--package/switch/Makefile2
-rw-r--r--target/linux/brcm47xx/base-files/lib/preinit/05_init_interfaces_brcm4
2 files changed, 1 insertions, 5 deletions
diff --git a/package/switch/Makefile b/package/switch/Makefile
index c577584803..fd1504e156 100644
--- a/package/switch/Makefile
+++ b/package/switch/Makefile
@@ -21,7 +21,7 @@ define KernelPackage/switch
$(PKG_BUILD_DIR)/switch-core.ko \
$(PKG_BUILD_DIR)/switch-adm.ko \
$(PKG_BUILD_DIR)/switch-robo.ko
- AUTOLOAD:=$(call AutoLoad,20,switch-core switch-robo switch-adm)
+ AUTOLOAD:=$(call AutoLoad,20,switch-core switch-robo switch-adm,1)
endef
define KernelPackage/switch/description
diff --git a/target/linux/brcm47xx/base-files/lib/preinit/05_init_interfaces_brcm b/target/linux/brcm47xx/base-files/lib/preinit/05_init_interfaces_brcm
index e85dd49f42..04992dee16 100644
--- a/target/linux/brcm47xx/base-files/lib/preinit/05_init_interfaces_brcm
+++ b/target/linux/brcm47xx/base-files/lib/preinit/05_init_interfaces_brcm
@@ -23,10 +23,6 @@ set_preinit_iface() {
}
init_iface() {
- insmod switch-core
- insmod switch-robo
- insmod switch-adm
-
[ -d /proc/switch/eth0 ] && [ "$ifname" = "eth0" ] && {
case "$(cat /proc/switch/eth0/cpuport)" in
"5") cpu_port="5u*";;