summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-04-12 19:18:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-04-12 19:18:38 +0000
commit3e91dd1bd509f3691a65b79d8ef2d02630aae479 (patch)
treecbe67a06b905c9400f885f9ee0b964548591a9ab /include
parentf3f941db39b21bdc1d629bac281f53ffb2a5eea1 (diff)
downloadmaster-31e0f0ae-3e91dd1bd509f3691a65b79d8ef2d02630aae479.tar.gz
master-31e0f0ae-3e91dd1bd509f3691a65b79d8ef2d02630aae479.tar.bz2
master-31e0f0ae-3e91dd1bd509f3691a65b79d8ef2d02630aae479.zip
revert find | xargs => find | exec changes - this is completely unnecessary and introduces additional dependencies that we do not need
SVN-Revision: 6942
Diffstat (limited to 'include')
-rw-r--r--include/image.mk6
-rw-r--r--include/package-ipkg.mk6
-rw-r--r--include/prereq-build.mk8
3 files changed, 6 insertions, 14 deletions
diff --git a/include/image.mk b/include/image.mk
index eb59ea651c..0e6a7cdbea 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -79,9 +79,9 @@ endif
define Image/mkfs/prepare/default
- find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' -exec chmod 0644 {} \;
- find $(BUILD_DIR)/root -type f -perm +0100 -exec chmod 0755 {} \;
- find $(BUILD_DIR)/root -type d -exec chmod 0755 {} \;
+ find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | xargs -r chmod 0644
+ find $(BUILD_DIR)/root -type f -perm +0100 | xargs -r chmod 0755
+ find $(BUILD_DIR)/root -type d | xargs -r chmod 0755
mkdir -p $(BUILD_DIR)/root/tmp
chmod 0777 $(BUILD_DIR)/root/tmp
endef
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 8b317065bf..86c802289c 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -71,9 +71,9 @@ ifeq ($(DUMP),)
$$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
$(call Package/$(1)/install,$$(IDIR_$(1)))
mkdir -p $(PACKAGE_DIR)
- -find $$(IDIR_$(1)) -name CVS -exec rm -rf {} +
- -find $$(IDIR_$(1)) -name .svn -exec rm -rf {} +
- -find $$(IDIR_$(1)) -name '.#*' -exec rm -f {} +
+ -find $$(IDIR_$(1)) -name CVS | xargs -r rm -rf
+ -find $$(IDIR_$(1)) -name .svn | xargs -r rm -rf
+ -find $$(IDIR_$(1)) -name '.#*' | xargs -r rm -f
$(RSTRIP) $$(IDIR_$(1))
$(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
@[ -f $$(IPKG_$(1)) ] || false
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 7355b9e31c..d3aec64399 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -121,11 +121,3 @@ $(eval $(call Require,gnutar, \
$(eval $(call RequireCommand,autoconf, \
Please install GNU autoconf. \
))
-
-define Require/find
- find . -maxdepth 1 -exec ls {} + > /dev/null 2>&1
-endef
-
-$(eval $(call Require,find, \
- Please install GNU find 4.2.12 or better. \
-))