summaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-03 22:03:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-03 22:03:50 +0000
commit86e2fbaaa4fc7a71dd99498624d249153ccc2954 (patch)
treec8c669c1edd5167a54f989841b176d00447e8371 /package/base-files/Makefile
parentc9dcbd5531225af936844b9a484dc384f688bebb (diff)
downloadmaster-31e0f0ae-86e2fbaaa4fc7a71dd99498624d249153ccc2954.tar.gz
master-31e0f0ae-86e2fbaaa4fc7a71dd99498624d249153ccc2954.tar.bz2
master-31e0f0ae-86e2fbaaa4fc7a71dd99498624d249153ccc2954.zip
rename the <boardname>-<kernelversion> directories of base-files to just <boardname>, so that the broadcom stuff can share files across kernel versions. adding back <boardname>-<kernelversion> for version specific overrides is still possible
SVN-Revision: 5427
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 9f6da3bc7c..f778219665 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -143,6 +143,9 @@ endef
define Package/base-files$(TARGET)/install
$(CP) ./default/* $(1)/
+ if [ -d $(BOARD) ]; then \
+ $(CP) $(BOARD)/* $(1)/; \
+ fi
if [ -d $(BOARD)-$(KERNEL) ]; then \
$(CP) $(BOARD)-$(KERNEL)/* $(1)/; \
fi