summaryrefslogtreecommitdiffstats
path: root/package/firewall/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-05-01 18:22:01 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-05-01 18:22:01 +0000
commitc284cb51c00625f52090f3fe3d475450eaab7b21 (patch)
tree02c49883956e50f28055df479accfa35c3c6fcdd /package/firewall/Makefile
parent085b2b9ad6216508ff357dcb49757173d269fbb9 (diff)
downloadmaster-31e0f0ae-c284cb51c00625f52090f3fe3d475450eaab7b21.tar.gz
master-31e0f0ae-c284cb51c00625f52090f3fe3d475450eaab7b21.tar.bz2
master-31e0f0ae-c284cb51c00625f52090f3fe3d475450eaab7b21.zip
firewall: - replace uci firewall with a modular dual stack implementation developed by Malte S. Stretz - bump version to 2
SVN-Revision: 21286
Diffstat (limited to 'package/firewall/Makefile')
-rw-r--r--package/firewall/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/package/firewall/Makefile b/package/firewall/Makefile
index abc6020434..22d359939f 100644
--- a/package/firewall/Makefile
+++ b/package/firewall/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,8 +8,8 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
-PKG_VERSION:=1
-PKG_RELEASE:=10
+PKG_VERSION:=2
+PKG_RELEASE:=1
include $(INCLUDE_DIR)/package.mk
@@ -36,13 +36,15 @@ endef
define Package/firewall/install
$(INSTALL_DIR) $(1)/lib/firewall
- $(INSTALL_DATA) ./files/uci_firewall.sh $(1)/lib/firewall
+ $(INSTALL_DATA) ./files/lib/*.sh $(1)/lib/firewall
+ $(INSTALL_DIR) $(1)/sbin
+ $(INSTALL_BIN) ./files/bin/fw $(1)/sbin
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_DATA) ./files/firewall.config $(1)/etc/config/firewall
$(INSTALL_DIR) $(1)/etc/init.d/
$(INSTALL_BIN) ./files/firewall.init $(1)/etc/init.d/firewall
$(INSTALL_DIR) $(1)/etc/hotplug.d/iface
- $(INSTALL_DATA) ./files/20-firewall $(1)/etc/hotplug.d/iface
+ $(INSTALL_DATA) ./files/firewall.hotplug $(1)/etc/hotplug.d/iface/20-firewall
$(INSTALL_DIR) $(1)/etc
$(INSTALL_DATA) ./files/firewall.user $(1)/etc
endef