summaryrefslogtreecommitdiffstats
path: root/package/iptables/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-02-24 01:59:32 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-02-24 01:59:32 +0000
commit0ab4d7e848ead11fcc85c04834519861682cd9ef (patch)
tree3d43b21d188acc9e0757feae707ff41bbf72ea0d /package/iptables/Makefile
parentb57690432c90c356d3f2d6edd3bbc565dc72a61c (diff)
downloadmaster-31e0f0ae-0ab4d7e848ead11fcc85c04834519861682cd9ef.tar.gz
master-31e0f0ae-0ab4d7e848ead11fcc85c04834519861682cd9ef.tar.bz2
master-31e0f0ae-0ab4d7e848ead11fcc85c04834519861682cd9ef.zip
iptables: fix a segfault when iptables tries to use modprobe, force it to use insmod
SVN-Revision: 19827
Diffstat (limited to 'package/iptables/Makefile')
-rw-r--r--package/iptables/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index 20e4b315ca..68ccc76282 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -254,6 +254,10 @@ TARGET_CPPFLAGS := \
-I$(LINUX_DIR)/arch/$(LINUX_KARCH)/include \
$(TARGET_CPPFLAGS)
+TARGET_CFLAGS := \
+ $(TARGET_CFLAGS) \
+ -DFORCE_MODPROBE_PROGRAM="\\\"/sbin/insmod\\\""
+
CONFIGURE_ARGS += \
--enable-shared \
--enable-devel \