summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-29 08:12:23 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-29 08:12:23 +0000
commitb2f3e852d0e42ee29f38c15033fadb736383bae1 (patch)
treed0fb998c24dcdba9127318ba055a9b190ae2b33b /package/kernel/linux/modules/other.mk
parent661f05262bec9fd6f5676e3e85283422aaf87bd6 (diff)
downloadmaster-31e0f0ae-b2f3e852d0e42ee29f38c15033fadb736383bae1.tar.gz
master-31e0f0ae-b2f3e852d0e42ee29f38c15033fadb736383bae1.tar.bz2
master-31e0f0ae-b2f3e852d0e42ee29f38c15033fadb736383bae1.zip
kernel: remove useless AddDepends/crc16 abstraction
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45133
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 86770b5a3b..1644f77ce4 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -29,7 +29,7 @@ $(eval $(call KernelPackage,6lowpan-iphc))
define KernelPackage/bluetooth
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth support
- DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +!LINUX_3_10:kmod-6lowpan-iphc
+ DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +!LINUX_3_10:kmod-6lowpan-iphc +kmod-lib-crc16
KCONFIG:= \
CONFIG_BLUEZ \
CONFIG_BLUEZ_L2CAP \
@@ -50,7 +50,6 @@ define KernelPackage/bluetooth
CONFIG_BT_HCIUART_H4 \
CONFIG_BT_HIDP \
CONFIG_HID_SUPPORT=y
- $(call AddDepends/crc16)
$(call AddDepends/hid)
$(call AddDepends/rfkill)
FILES:= \