summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-12-22 16:58:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-12-22 16:58:45 +0000
commit854c77bcea2ed4ebf3faebcc45acf9a82b0f72d8 (patch)
tree184d99d36b8d1e38d42b8de40128995b2641e656 /package/kernel/linux
parent0f18228a3af47704813698a1fdf5f9ebd3e0242d (diff)
downloadmaster-31e0f0ae-854c77bcea2ed4ebf3faebcc45acf9a82b0f72d8.tar.gz
master-31e0f0ae-854c77bcea2ed4ebf3faebcc45acf9a82b0f72d8.tar.bz2
master-31e0f0ae-854c77bcea2ed4ebf3faebcc45acf9a82b0f72d8.zip
kernel: make kmod-gpiofan depend on kmod-thermal to fix build errors
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 47960
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/hwmon.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index ca0ff66172..ad1c7bf91d 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -274,7 +274,7 @@ define KernelPackage/hwmon-gpiofan
KCONFIG:=CONFIG_SENSORS_GPIO_FAN
FILES:=$(LINUX_DIR)/drivers/hwmon/gpio-fan.ko
AUTOLOAD:=$(call AutoLoad,60,gpio-fan)
- $(call AddDepends/hwmon,+kmod-i2c-core)
+ $(call AddDepends/hwmon,+kmod-i2c-core +kmod-thermal)
endef
define KernelPackage/hwmon-gpiofan/description