summaryrefslogtreecommitdiffstats
path: root/package/kernel/modules
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-07-19 12:22:26 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-07-19 12:22:26 +0000
commit5066aab06b85d46c51fb17245ced63a65f48b8c3 (patch)
tree5464af20e11fe98db6b8306efaa08e1e4f2516db /package/kernel/modules
parentf60334ddc01f536c0f4b081170fa08608d27a614 (diff)
downloadmaster-31e0f0ae-5066aab06b85d46c51fb17245ced63a65f48b8c3.tar.gz
master-31e0f0ae-5066aab06b85d46c51fb17245ced63a65f48b8c3.tar.bz2
master-31e0f0ae-5066aab06b85d46c51fb17245ced63a65f48b8c3.zip
kernel/modules: package I2C bus driver for PPC4xx based systems
SVN-Revision: 16919
Diffstat (limited to 'package/kernel/modules')
-rw-r--r--package/kernel/modules/i2c.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/modules/i2c.mk b/package/kernel/modules/i2c.mk
index 444cc874f5..67713f300d 100644
--- a/package/kernel/modules/i2c.mk
+++ b/package/kernel/modules/i2c.mk
@@ -126,3 +126,19 @@ endef
$(eval $(call KernelPackage,i2c-scx200-acb))
+define KernelPackage/i2c-ibm-iic
+ SUBMENU:=$(I2C_MENU)
+ TITLE:=IBM PPC 4xx on-chip I2C interface support
+ DEPENDS:=@TARGET_ppc40x||TARGET_ppc4xx +kmod-i2c-core
+ KCONFIG:=CONFIG_I2C_IBM_IIC
+ FILES:=$(LINUX_DIR)/drivers/i2c/busses/i2c-ibm_iic.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,59,i2c-ibm_iic)
+endef
+
+define KernelPackage/i2c-ibm-iic/description
+ Kernel module for IIC peripheral found on embedded IBM PPC4xx based systems.
+endef
+
+$(eval $(call KernelPackage,i2c-ibm-iic))
+
+