summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2014-09-13 20:35:10 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2014-09-13 20:35:10 +0000
commita8e1a031a805d21e40a1e3d20f0176061579720f (patch)
treef3eaea5071da177e7ae6b6c9f380a64b84af1646 /package/kernel
parent9a428dd8d5443523db634c2fcec5a2d9c78b3d3a (diff)
downloadmaster-31e0f0ae-a8e1a031a805d21e40a1e3d20f0176061579720f.tar.gz
master-31e0f0ae-a8e1a031a805d21e40a1e3d20f0176061579720f.tar.bz2
master-31e0f0ae-a8e1a031a805d21e40a1e3d20f0176061579720f.zip
package: other.mk: update configuration for ad799x
The ad799x driver moved out of staging since kernel 3.16, so update filepath, config elements and description. Signed-off-by: Hartmut Knaack <knaack.h@gmx.de> SVN-Revision: 42524
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/other.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 2f6f774e1f..199e4573f3 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -242,14 +242,18 @@ define KernelPackage/iio-ad799x
KCONFIG:= \
CONFIG_AD799X_RING_BUFFER=y \
CONFIG_AD799X
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.16.0)),1)
+ FILES:=$(LINUX_DIR)/drivers/iio/adc/ad799x.ko
+else
FILES:=$(LINUX_DIR)/drivers/staging/iio/adc/ad799x.ko
+endif
AUTOLOAD:=$(call AutoLoad,56,ad799x)
endef
define KernelPackage/iio-ad799x/description
support for Analog Devices:
ad7991, ad7995, ad7999, ad7992, ad7993, ad7994, ad7997, ad7998
- i2c analog to digital converters (ADC). WARNING! This driver is still staging!
+ i2c analog to digital converters (ADC).
endef
$(eval $(call KernelPackage,iio-ad799x))