summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-09-06 11:41:09 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-09-06 11:41:09 +0000
commite9996f7cdca15e5dd5311ae205f5fcac690e4988 (patch)
treed7f8209181061916498d65ed98446420762844b7 /package/kernel
parent5510149e78cb9123c602fc7a1a0b4fde689ff464 (diff)
downloadmaster-31e0f0ae-e9996f7cdca15e5dd5311ae205f5fcac690e4988.tar.gz
master-31e0f0ae-e9996f7cdca15e5dd5311ae205f5fcac690e4988.tar.bz2
master-31e0f0ae-e9996f7cdca15e5dd5311ae205f5fcac690e4988.zip
package/kernel: update crypto.mk for kernel 2.6.36
SVN-Revision: 22954
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/crypto.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/kernel/modules/crypto.mk b/package/kernel/modules/crypto.mk
index 421e37fa71..9227deb80b 100644
--- a/package/kernel/modules/crypto.mk
+++ b/package/kernel/modules/crypto.mk
@@ -267,7 +267,8 @@ define KernelPackage/crypto-misc
$(LINUX_DIR)/crypto/sha256$(SHA256_SUFFIX).ko \
$(LINUX_DIR)/crypto/sha512$(SHA512_SUFFIX).ko \
$(LINUX_DIR)/crypto/tea.ko \
- $(LINUX_DIR)/crypto/twofish.ko \
+ $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),le,2.6.35)),,$(LINUX_DIR)/crypto/twofish.ko) \
+ $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.36)),,$(LINUX_DIR)/crypto/twofish_generic.ko) \
$(LINUX_DIR)/crypto/wp512.ko
$(call AddDepends/crypto)
endef