summaryrefslogtreecommitdiffstats
path: root/package/kexec-tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-28 13:28:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-28 13:28:18 +0000
commit15a9b61bbd1c7d1dec7cdb0992462356aec63905 (patch)
tree8b254a70414006b5e5905f6c98712247aa86ed1c /package/kexec-tools/Makefile
parent74f71f073998a53fb09409d59df65d1c03e94001 (diff)
downloadmaster-31e0f0ae-15a9b61bbd1c7d1dec7cdb0992462356aec63905.tar.gz
master-31e0f0ae-15a9b61bbd1c7d1dec7cdb0992462356aec63905.tar.bz2
master-31e0f0ae-15a9b61bbd1c7d1dec7cdb0992462356aec63905.zip
fix kexec-tools build
SVN-Revision: 6428
Diffstat (limited to 'package/kexec-tools/Makefile')
-rw-r--r--package/kexec-tools/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/package/kexec-tools/Makefile b/package/kexec-tools/Makefile
index 23294fd39b..d88fc0583c 100644
--- a/package/kexec-tools/Makefile
+++ b/package/kexec-tools/Makefile
@@ -33,12 +33,17 @@ define Package/kexec-tools
URL:=http://www.xmission.com/~ebiederm/files/kexec/README
endef
+MAKE_FLAGS += \
+ DESTDIR="$(PKG_INSTALL_DIR)" \
+ EXTRA_CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
+ BUILD_CFLAGS="-O2" \
+ LIBS="$(TARGET_LDFLAGS) -lz" \
+ install
+
define Build/Compile
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- install
+ $(call Build/Compile/Default,)
endef
define Package/kexec-tools/install