summaryrefslogtreecommitdiffstats
path: root/package/mac80211/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2008-04-15 02:08:11 +0000
committerNicolas Thill <nico@openwrt.org>2008-04-15 02:08:11 +0000
commit2a4a0c2bcccdd56d23bd00aabb457da21876eb3a (patch)
treeb0fe32c81da46cd261869152678f446604d28a96 /package/mac80211/Makefile
parentd07eb95838190f3bcd7f0528e519e988be5735af (diff)
downloadmaster-31e0f0ae-2a4a0c2bcccdd56d23bd00aabb457da21876eb3a.tar.gz
master-31e0f0ae-2a4a0c2bcccdd56d23bd00aabb457da21876eb3a.tar.bz2
master-31e0f0ae-2a4a0c2bcccdd56d23bd00aabb457da21876eb3a.zip
explicitely disable a bunch of package on ar7 until we properly detect pci & usb support at configure time
SVN-Revision: 10839
Diffstat (limited to 'package/mac80211/Makefile')
-rw-r--r--package/mac80211/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index 9370b1d113..749c8c1714 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -19,6 +19,8 @@ PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/compat-wireless-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
+# XXX: remove @!TARGET_* later when we have PCI & USB support properly detected on all targets
+
define KernelPackage/mac80211
SUBMENU:=Wireless Drivers
TITLE:=Linux 802.11 Wireless Networking Stack
@@ -54,7 +56,7 @@ $(eval $(call Download,rt71w))
define KernelPackage/rt2x00/Default
SUBMENU:=Wireless Drivers
TITLE:=Ralink Drivers for RT2x00 cards
- DEPENDS:=@LINUX_2_6_24 @!TARGET_atheros @!TARGET_uml
+ DEPENDS:=@LINUX_2_6_24 @!TARGET_ar7 @!TARGET_atheros @!TARGET_uml
endef
define KernelPackage/rt2x00-lib