summaryrefslogtreecommitdiffstats
path: root/package/mac80211/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2008-04-13 13:35:02 +0000
committerNicolas Thill <nico@openwrt.org>2008-04-13 13:35:02 +0000
commit98f3ce25451416619d5012b9722d901c13a1501b (patch)
treecb9f4e620a878cff157054ffc7a2947d5b0f8390 /package/mac80211/Makefile
parentcb30800bf6c55c008f0264a5f304f6916a2731af (diff)
downloadmaster-31e0f0ae-98f3ce25451416619d5012b9722d901c13a1501b.tar.gz
master-31e0f0ae-98f3ce25451416619d5012b9722d901c13a1501b.tar.bz2
master-31e0f0ae-98f3ce25451416619d5012b9722d901c13a1501b.zip
mac80211 / compat-wireless fixes: * build in KERNEL_BUILD_DIR * only build kernel module if it's selected
SVN-Revision: 10815
Diffstat (limited to 'package/mac80211/Makefile')
-rw-r--r--package/mac80211/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index fb01c76f49..9370b1d113 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -15,7 +15,7 @@ PKG_RELEASE:=1
PKG_VERSION:=2008-04-07
PKG_SOURCE:=compat-wireless-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://linuxwireless.org/download/compat-wireless-2.6/
-PKG_BUILD_DIR:=$(BUILD_DIR)/compat-wireless-$(PKG_VERSION)
+PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/compat-wireless-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
@@ -177,8 +177,14 @@ define Build/Prepare
unzip -jod $(PKG_BUILD_DIR) $(DL_DIR)/$(RT71FW)
endef
-define Build/Compile
+ifneq ($(CONFIG_PACKAGE_kmod-mac80211),)
+ define Build/Compile/kmod
$(MAKE) -C "$(PKG_BUILD_DIR)" $(MAKE_OPTS) all
+ endef
+endif
+
+define Build/Compile
+ $(call Build/Compile/kmod)
endef
define Build/InstallDev