summaryrefslogtreecommitdiffstats
path: root/package/mac80211/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2009-08-15 08:36:33 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2009-08-15 08:36:33 +0000
commitb1ae2c2c20e7a7d51e86d4cf70feb61da3894754 (patch)
tree884b249e246abe2d0a96ad4ba5551061aadc5f18 /package/mac80211/Makefile
parentbabf8f5927f0cf93a7d522934f509c6ff4c902d0 (diff)
downloadmaster-31e0f0ae-b1ae2c2c20e7a7d51e86d4cf70feb61da3894754.tar.gz
master-31e0f0ae-b1ae2c2c20e7a7d51e86d4cf70feb61da3894754.tar.bz2
master-31e0f0ae-b1ae2c2c20e7a7d51e86d4cf70feb61da3894754.zip
Build modules only if realy needed.
SVN-Revision: 17267
Diffstat (limited to 'package/mac80211/Makefile')
-rw-r--r--package/mac80211/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index e09647307a..695cfb8c49 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -456,6 +456,26 @@ MAKE_OPTS:= \
$(if $(CONFIG_HW_RANDOM),CONFIG_B43LEGACY_HWRNG=y,CONFIG_B43LEGACY_HWRNG=n) \
$(if $(CONFIG_PACKAGE_kmod-b43),CONFIG_B43=m) \
$(if $(CONFIG_PACKAGE_kmod-b43legacy),CONFIG_B43LEGACY=m) \
+ $(if $(CONFIG_PACKAGE_kmod-ath),CONFIG_ATH_COMMON=m) \
+ $(if $(CONFIG_PACKAGE_kmod-ath5k),CONFIG_ATH5K=m) \
+ $(if $(CONFIG_PACKAGE_kmod-ath9k),CONFIG_ATH9K=m) \
+ $(if $(CONFIG_PACKAGE_kmod-zd1211rw),CONFIG_ZD1211RW=m) \
+ $(if $(CONFIG_PACKAGE_kmod-p54-common),CONFIG_P54_COMMON=m) \
+ $(if $(CONFIG_PACKAGE_kmod-p54-pci),CONFIG_P54_PCI=m) \
+ $(if $(CONFIG_PACKAGE_kmod-p54-usb),CONFIG_P54_USB=m) \
+ $(if $(CONFIG_PACKAGE_kmod-rt2x00-lib),CONFIG_RT2X00=m) \
+ $(if $(CONFIG_PACKAGE_kmod-rt2x00-pci),CONFIG_RT2X00_LIB_PCI=m) \
+ $(if $(CONFIG_PACKAGE_kmod-rt2x00-usb),CONFIG_RT2X00_LIB_USB=m) \
+ $(if $(CONFIG_PACKAGE_kmod-rt2400-pci),CONFIG_RT2400PCI=m) \
+ $(if $(CONFIG_PACKAGE_kmod-rt2500-pci),CONFIG_RT2500PCI=m) \
+ $(if $(CONFIG_PACKAGE_kmod-rt2500-usb),CONFIG_RT2500USB=m) \
+ $(if $(CONFIG_PACKAGE_kmod-rt61-pci),CONFIG_RT61PCI=m) \
+ $(if $(CONFIG_PACKAGE_kmod-rt73-usb),CONFIG_RT73USB=m) \
+ $(if $(CONFIG_PACKAGE_kmod-rt2800-pci),CONFIG_RT2800PCI=m) \
+ $(if $(CONFIG_PACKAGE_kmod-rt2800-usb),CONFIG_RT2800USB=m) \
+ $(if $(CONFIG_PACKAGE_kmod-rtl8180),CONFIG_RTL8180=m) \
+ $(if $(CONFIG_PACKAGE_kmod-rtl8187),CONFIG_RTL8187=m) \
+ $(if $(CONFIG_PACKAGE_kmod-mac80211-hwsim),CONFIG_MAC80211_HWSIM=m) \
KLIB_BUILD="$(LINUX_DIR)" \
MODPROBE=: