summaryrefslogtreecommitdiffstats
path: root/package/mac80211/patches/520-b43-autodepend-on-hwrandom.patch
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2009-04-06 17:15:19 +0000
committerMichael Büsch <mb@bu3sch.de>2009-04-06 17:15:19 +0000
commitcb70a62be333c183db137102fffae8b0d4bd95b2 (patch)
treeaf428dd54a36dfbd1d0d12014cccee69b4331430 /package/mac80211/patches/520-b43-autodepend-on-hwrandom.patch
parent3072d928f801294fc5c3b0e311eac2b4f1b29613 (diff)
downloadmaster-31e0f0ae-cb70a62be333c183db137102fffae8b0d4bd95b2.tar.gz
master-31e0f0ae-cb70a62be333c183db137102fffae8b0d4bd95b2.tar.bz2
master-31e0f0ae-cb70a62be333c183db137102fffae8b0d4bd95b2.zip
b43: Add DMA poisoning patches
SVN-Revision: 15121
Diffstat (limited to 'package/mac80211/patches/520-b43-autodepend-on-hwrandom.patch')
-rw-r--r--package/mac80211/patches/520-b43-autodepend-on-hwrandom.patch20
1 files changed, 13 insertions, 7 deletions
diff --git a/package/mac80211/patches/520-b43-autodepend-on-hwrandom.patch b/package/mac80211/patches/520-b43-autodepend-on-hwrandom.patch
index 9ffdadfd26..6cc8ea9212 100644
--- a/package/mac80211/patches/520-b43-autodepend-on-hwrandom.patch
+++ b/package/mac80211/patches/520-b43-autodepend-on-hwrandom.patch
@@ -4,9 +4,11 @@ This patch is submitted upstream and can be removed when it hits compat-wireless
---- a/drivers/net/wireless/b43/b43.h
-+++ b/drivers/net/wireless/b43/b43.h
-@@ -624,9 +624,11 @@ struct b43_wl {
+Index: compat-wireless-2009-03-31/drivers/net/wireless/b43/b43.h
+===================================================================
+--- compat-wireless-2009-03-31.orig/drivers/net/wireless/b43/b43.h 2009-04-06 18:52:21.000000000 +0200
++++ compat-wireless-2009-03-31/drivers/net/wireless/b43/b43.h 2009-04-06 18:53:19.000000000 +0200
+@@ -625,9 +625,11 @@ struct b43_wl {
/* Stats about the wireless interface */
struct ieee80211_low_level_stats ieee_stats;
@@ -19,8 +21,10 @@ This patch is submitted upstream and can be removed when it hits compat-wireless
/* The RF-kill button */
struct b43_rfkill rfkill;
---- a/drivers/net/wireless/b43/main.c
-+++ b/drivers/net/wireless/b43/main.c
+Index: compat-wireless-2009-03-31/drivers/net/wireless/b43/main.c
+===================================================================
+--- compat-wireless-2009-03-31.orig/drivers/net/wireless/b43/main.c 2009-04-06 18:52:28.000000000 +0200
++++ compat-wireless-2009-03-31/drivers/net/wireless/b43/main.c 2009-04-06 18:53:19.000000000 +0200
@@ -2982,6 +2982,7 @@ static void b43_security_init(struct b43
b43_clear_keys(dev);
}
@@ -60,8 +64,10 @@ This patch is submitted upstream and can be removed when it hits compat-wireless
return err;
}
---- a/config.mk
-+++ b/config.mk
+Index: compat-wireless-2009-03-31/config.mk
+===================================================================
+--- compat-wireless-2009-03-31.orig/config.mk 2009-04-06 18:52:21.000000000 +0200
++++ compat-wireless-2009-03-31/config.mk 2009-04-06 18:53:19.000000000 +0200
@@ -148,6 +148,7 @@ CONFIG_ATH9K_DEBUG=y
# CONFIG_B43_PIO=y
# CONFIG_B43_LEDS=y