summaryrefslogtreecommitdiffstats
path: root/package/network/ipv6/map/Makefile
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2014-05-22 20:04:53 +0000
committerSteven Barth <cyrus@openwrt.org>2014-05-22 20:04:53 +0000
commitbb932910dd0c764d323789ebb9a8c214059bbd1d (patch)
treec6e99f2c8f1ad429f458bac81cc23936c0ed7f52 /package/network/ipv6/map/Makefile
parent32246436147f1e022a09a4bcd78778350c099e77 (diff)
downloadmaster-31e0f0ae-bb932910dd0c764d323789ebb9a8c214059bbd1d.tar.gz
master-31e0f0ae-bb932910dd0c764d323789ebb9a8c214059bbd1d.tar.bz2
master-31e0f0ae-bb932910dd0c764d323789ebb9a8c214059bbd1d.zip
Initial support for MAP-E and Lightweight 4over6 protocol
SVN-Revision: 40823
Diffstat (limited to 'package/network/ipv6/map/Makefile')
-rw-r--r--package/network/ipv6/map/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/package/network/ipv6/map/Makefile b/package/network/ipv6/map/Makefile
new file mode 100644
index 0000000000..f965afd6d3
--- /dev/null
+++ b/package/network/ipv6/map/Makefile
@@ -0,0 +1,44 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=map
+PKG_VERSION:=1
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/map
+ SECTION:=net
+ CATEGORY:=Network
+ DEPENDS:=+kmod-ipv6 +kmod-ip6-tunnel +libubox +libubus +iptables-mod-conntrack-extra
+ TITLE:=MAP-E and Lightweight 4over6 configuration support
+ MAINTAINER:=Steven Barth <steven@midlink.org>
+endef
+
+define Package/map/description
+ Provides support for MAP-E (draft-ietf-softwire-map) and
+ Lightweight 4over6 (draft-ietf-softwire-lw4over6) in /etc/config/network.
+ Refer to http://wiki.openwrt.org/doc/uci/network for
+ configuration details.
+endef
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Package/map/install
+ $(INSTALL_DIR) $(1)/lib/netifd/proto
+ $(INSTALL_BIN) ./files/map.sh $(1)/lib/netifd/proto/map.sh
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/mapcalc $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,map))