summaryrefslogtreecommitdiffstats
path: root/package/ppp
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-01-17 00:14:18 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-01-17 00:14:18 +0000
commit5cf136ae0eed9dc82548f736b47e5d128c5f438e (patch)
tree68ff80f541e175e01431b48d407575716807fab7 /package/ppp
parentbad3c4865d0302a10266105bac43af44dd926382 (diff)
downloadmaster-31e0f0ae-5cf136ae0eed9dc82548f736b47e5d128c5f438e.tar.gz
master-31e0f0ae-5cf136ae0eed9dc82548f736b47e5d128c5f438e.tar.bz2
master-31e0f0ae-5cf136ae0eed9dc82548f736b47e5d128c5f438e.zip
ppp: synthesize a .device option to make ifup work on pppoa interfaces again
SVN-Revision: 25025
Diffstat (limited to 'package/ppp')
-rw-r--r--package/ppp/Makefile2
-rw-r--r--package/ppp/files/pppoa.sh4
2 files changed, 5 insertions, 1 deletions
diff --git a/package/ppp/Makefile b/package/ppp/Makefile
index eae32d0439..5be8e7cce5 100644
--- a/package/ppp/Makefile
+++ b/package/ppp/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ppp
PKG_VERSION:=2.4.4
-PKG_RELEASE:=13
+PKG_RELEASE:=14
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
diff --git a/package/ppp/files/pppoa.sh b/package/ppp/files/pppoa.sh
index df947aa83d..c64e809de3 100644
--- a/package/ppp/files/pppoa.sh
+++ b/package/ppp/files/pppoa.sh
@@ -1,3 +1,7 @@
+scan_pppoa() {
+ config_set "$1" device "pppoa-$1"
+}
+
coldplug_interface_pppoa() {
setup_interface_pppoa x "$1"
}