summaryrefslogtreecommitdiffstats
path: root/package/procd/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-03-13 18:11:07 +0000
committerJohn Crispin <john@openwrt.org>2013-03-13 18:11:07 +0000
commit32ebaf0cec183f87596094b10b2f0ab8e786a9b3 (patch)
tree775392d47417f0029aff9b9011d9ee92436f6edb /package/procd/Makefile
parent043d56b646019995c8fb4be2dbf36c204ae75392 (diff)
downloadmaster-31e0f0ae-32ebaf0cec183f87596094b10b2f0ab8e786a9b3.tar.gz
master-31e0f0ae-32ebaf0cec183f87596094b10b2f0ab8e786a9b3.tar.bz2
master-31e0f0ae-32ebaf0cec183f87596094b10b2f0ab8e786a9b3.zip
update to latest git head
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 36001
Diffstat (limited to 'package/procd/Makefile')
-rw-r--r--package/procd/Makefile19
1 files changed, 16 insertions, 3 deletions
diff --git a/package/procd/Makefile b/package/procd/Makefile
index 0330905577..25b0271b37 100644
--- a/package/procd/Makefile
+++ b/package/procd/Makefile
@@ -1,19 +1,21 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=procd
-PKG_VERSION:=2012-12-20
+PKG_VERSION:=2012-03-13
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=d343dd9e9a64d4ae7d225ea29169e97fa8d116a1
+PKG_SOURCE_VERSION:=8158e9052afbf2ee47de645167b90b6e7fc7d86d
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
CMAKE_INSTALL:=1
PKG_LICENSE:=GPLv2
PKG_LICENSE_FILES:=
+PKG_CONFIG_DEPENDS:=CONFIG_PROCD_INIT
+
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
include $(INCLUDE_DIR)/package.mk
@@ -22,10 +24,20 @@ include $(INCLUDE_DIR)/cmake.mk
define Package/procd
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+ubusd +ubus
+ DEPENDS:=+ubusd +ubus +libjson_script
TITLE:=OpenWrt system process manager
endef
+ifneq ($(CONFIG_PROCD_INIT),)
+define Package/procd/install
+ $(INSTALL_DIR) $(1)/sbin $(1)/lib/functions $(1)/etc
+
+ $(CP) $(PKG_INSTALL_DIR)/usr/sbin/{procd,askfirst,udevtrigger,logread} $(1)/sbin/
+ $(INSTALL_DATA) ./files/hotplug*.json $(1)/etc/
+ $(INSTALL_DATA) ./files/procd.sh $(1)/lib/functions/
+ ln -s /sbin/procd $(1)/sbin/init
+endef
+else
define Package/procd/install
$(INSTALL_DIR) $(1)/sbin $(1)/lib/functions $(1)/etc/init.d
@@ -33,5 +45,6 @@ define Package/procd/install
$(INSTALL_BIN) ./files/procd.init $(1)/etc/init.d/procd
$(INSTALL_DATA) ./files/procd.sh $(1)/lib/functions/
endef
+endif
$(eval $(call BuildPackage,procd))