summaryrefslogtreecommitdiffstats
path: root/package/system/mtd/src/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-08-19 08:31:23 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-08-19 08:31:23 +0000
commit20fac016e432cf384289b3fefadf3f4909924faf (patch)
tree2eac7cea31b2af956fe1a2cb5b2624697efe30e8 /package/system/mtd/src/Makefile
parent996399ba08e4a3c372e4029f0d76a495c7f46f7b (diff)
downloadmaster-31e0f0ae-20fac016e432cf384289b3fefadf3f4909924faf.tar.gz
master-31e0f0ae-20fac016e432cf384289b3fefadf3f4909924faf.tar.bz2
master-31e0f0ae-20fac016e432cf384289b3fefadf3f4909924faf.zip
mvebu: add support for the Linksys boot counter
The u-boot boot counter was never reset after a successful boot, which sometimes could make some variables become out of sync. This patch adds support for the boot counter and enables auto_recovery unconditionally. Signed-off-by: Jonas Gorski <jogo@openwrt.org> Signed-off-by: Rob Mosher <nyt-openwrt@countercultured.net> Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 46690
Diffstat (limited to 'package/system/mtd/src/Makefile')
-rw-r--r--package/system/mtd/src/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/system/mtd/src/Makefile b/package/system/mtd/src/Makefile
index 27ac339005..40a165e4e6 100644
--- a/package/system/mtd/src/Makefile
+++ b/package/system/mtd/src/Makefile
@@ -10,6 +10,7 @@ obj.brcm47xx = $(obj.brcm)
obj.bcm53xx = $(obj.brcm)
obj.brcm63xx = imagetag.o
obj.ramips = $(obj.seama)
+obj.mvebu = linksys_bootcount.o
ifdef FIS_SUPPORT
obj += fis.o