summaryrefslogtreecommitdiffstats
path: root/package/uboot-lantiq/files/board/infineon/easy50812/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2011-07-06 10:36:35 +0000
committerJohn Crispin <john@openwrt.org>2011-07-06 10:36:35 +0000
commitb808c1bc03363e4c7e5be7b07e8ab8be550c6ba3 (patch)
treee7b49095a024a96651eb037011504d24080bd965 /package/uboot-lantiq/files/board/infineon/easy50812/Makefile
parentc93b5653bc9866cb7700e50e2a2f914bfcfbf677 (diff)
downloadmaster-31e0f0ae-b808c1bc03363e4c7e5be7b07e8ab8be550c6ba3.tar.gz
master-31e0f0ae-b808c1bc03363e4c7e5be7b07e8ab8be550c6ba3.tar.bz2
master-31e0f0ae-b808c1bc03363e4c7e5be7b07e8ab8be550c6ba3.zip
fix lantiq uboot to build lzma compressed bootloaders for eval kits
SVN-Revision: 27487
Diffstat (limited to 'package/uboot-lantiq/files/board/infineon/easy50812/Makefile')
-rw-r--r--package/uboot-lantiq/files/board/infineon/easy50812/Makefile19
1 files changed, 17 insertions, 2 deletions
diff --git a/package/uboot-lantiq/files/board/infineon/easy50812/Makefile b/package/uboot-lantiq/files/board/infineon/easy50812/Makefile
index 44d8ea3443..97d1898954 100644
--- a/package/uboot-lantiq/files/board/infineon/easy50812/Makefile
+++ b/package/uboot-lantiq/files/board/infineon/easy50812/Makefile
@@ -24,19 +24,34 @@
include $(TOPDIR)/config.mk
LIB = $(obj)lib$(BOARD).a
+BOOTSTRAP_LIB = $(obj)lib$(BOARD)_bootstrap.a
+
+BOOTSTRAP_LIB-$(CONFIG_BOOTSTRAP) = $(BOOTSTRAP_LIB)
-#COBJS := $(BOARD).o
COBJS-y += ar9.o
SOBJS = lowlevel_init.o pmuenable.o
-SRCS := $(SOBJS:.o=.S) $(COBJS-y:.o=.c)
+BOOTSTRAP_COBJS-$(CONFIG_BOOTSTRAP) = $(BOARD)_bootstrap.o
+BOOTSTRAP_SOBJS-$(CONFIG_BOOTSTRAP) = lowlevel_bootstrap_init.o
+
+BOOTSTRAP_SRCS := $(BOOTSTRAP_SOBJS-y:.o=.S) $(BOOTSTRAP_COBJS-y:.o=.c)
+
+SRCS := $(sort $(SOBJS:.o=.S) $(COBJS:.o=.c) $(BOOTSTRAP_SOBJS:.o=.S))
OBJS := $(addprefix $(obj),$(COBJS-y))
SOBJS := $(addprefix $(obj),$(SOBJS))
+BOOTSTRAP_OBJS := $(addprefix $(obj),$(BOOTSTRAP_COBJS-y))
+BOOTSTRAP_SOBJS := $(addprefix $(obj),$(BOOTSTRAP_SOBJS-y))
+
+
+all: $(obj).depend $(LIB) $(BOOTSTRAP_LIB)
$(LIB): $(obj).depend $(OBJS) $(SOBJS)
$(AR) $(ARFLAGS) $@ $(OBJS) $(SOBJS)
+$(BOOTSTRAP_LIB): $(BOOTSTRAP_OBJS) $(BOOTSTRAP_SOBJS)
+ $(AR) $(ARFLAGS) $@ $(BOOTSTRAP_OBJS) $(BOOTSTRAP_SOBJS)
+
#########################################################################
# defines $(obj).depend target