summaryrefslogtreecommitdiffstats
path: root/package/uboot-lantiq/files/board/infineon/easy50812/config.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2011-07-06 10:36:35 +0000
committerJohn Crispin <john@openwrt.org>2011-07-06 10:36:35 +0000
commitb808c1bc03363e4c7e5be7b07e8ab8be550c6ba3 (patch)
treee7b49095a024a96651eb037011504d24080bd965 /package/uboot-lantiq/files/board/infineon/easy50812/config.mk
parentc93b5653bc9866cb7700e50e2a2f914bfcfbf677 (diff)
downloadmaster-31e0f0ae-b808c1bc03363e4c7e5be7b07e8ab8be550c6ba3.tar.gz
master-31e0f0ae-b808c1bc03363e4c7e5be7b07e8ab8be550c6ba3.tar.bz2
master-31e0f0ae-b808c1bc03363e4c7e5be7b07e8ab8be550c6ba3.zip
fix lantiq uboot to build lzma compressed bootloaders for eval kits
SVN-Revision: 27487
Diffstat (limited to 'package/uboot-lantiq/files/board/infineon/easy50812/config.mk')
-rw-r--r--package/uboot-lantiq/files/board/infineon/easy50812/config.mk30
1 files changed, 5 insertions, 25 deletions
diff --git a/package/uboot-lantiq/files/board/infineon/easy50812/config.mk b/package/uboot-lantiq/files/board/infineon/easy50812/config.mk
index c0e5d82445..b110f6f329 100644
--- a/package/uboot-lantiq/files/board/infineon/easy50812/config.mk
+++ b/package/uboot-lantiq/files/board/infineon/easy50812/config.mk
@@ -26,35 +26,15 @@
#
sinclude $(OBJTREE)/board/$(BOARDDIR)/config.tmp
-ifdef CONFIG_LZMA_BOOTSTRAP
-
-ifdef BUILD_BOOTSTRAP
-
-$(info BUILD_BOOTSTRAP )
-#TEXT_BASE = 0xB0000000
-TEXT_BASE = 0x80010000
-
-else # BUILD_BOOTSTRAP
-
-ifndef TEXT_BASE
-$(info redefine TEXT_BASE = 0x80040000 )
-TEXT_BASE = 0x80040000
-endif
-
-endif # BUILD_BOOTSTRAP
-
+ifdef CONFIG_BOOTSTRAP
+TEXT_BASE = 0x80001000
+CONFIG_BOOTSTRAP_TEXT_BASE = 0xb0000000
+CONFIG_SYS_RAMBOOT = y
else
-ifdef BUILD_BOOTSTRAP
-$(error BUILD_BOOTSTRAP but not enabled in config)
-endif
-
ifndef TEXT_BASE
-## Standard: boot from ebu
$(info redefine TEXT_BASE = 0xB0000000 )
TEXT_BASE = 0xB0000000
-## For testing: boot from RAM
-# TEXT_BASE = 0x80100000
endif
-endif # CONFIG_LZMA_BOOTSTRAP
+endif