summaryrefslogtreecommitdiffstats
path: root/package/utils/px5g-standalone/src/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-03-21 15:55:23 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-03-21 15:55:23 +0000
commiteb225996ee9591eaa4ad74cd6040038bd35b92cb (patch)
tree7bb18c307fb3dae7960224b7408ef04be717cbc5 /package/utils/px5g-standalone/src/Makefile
parent6d270ebc2b25b576a2dfdcaaa406b116f6353ea9 (diff)
downloadmaster-31e0f0ae-eb225996ee9591eaa4ad74cd6040038bd35b92cb.tar.gz
master-31e0f0ae-eb225996ee9591eaa4ad74cd6040038bd35b92cb.tar.bz2
master-31e0f0ae-eb225996ee9591eaa4ad74cd6040038bd35b92cb.zip
px5g: rename the old package to px5g-standalone, add a new one that links against polarssl
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 40000
Diffstat (limited to 'package/utils/px5g-standalone/src/Makefile')
-rw-r--r--package/utils/px5g-standalone/src/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/utils/px5g-standalone/src/Makefile b/package/utils/px5g-standalone/src/Makefile
new file mode 100644
index 0000000000..2bd95739cb
--- /dev/null
+++ b/package/utils/px5g-standalone/src/Makefile
@@ -0,0 +1,14 @@
+CFLAGS?=-O2
+CFLAGS+=
+SFLAGS:=--std=gnu99
+WFLAGS:=-Wall -Werror -pedantic
+LDFLAGS?=
+BINARY:=px5g
+
+all: $(BINARY)
+
+$(BINARY): *.c library/*.c
+ $(CC) -I. $(CFLAGS) $(SFLAGS) $(WFLAGS) $(LDFLAGS) -o $@ $+
+
+clean:
+ rm -f $(BINARY)